A new power supply - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Overclocking and Modding
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 06-04-2005, 06:41 PM   #11 (permalink)
Ultra Techie
 
Join Date: Apr 2004
Posts: 858
Default

there are 20 and 24 pin mobo connectors, they have adaptors if it doesn't fit, most older mobos are 20 pin, what you need to consider is amperage and watts, you prolly want a minimum of 420w and 16amps
__________________

GageMW is offline  
Old 06-04-2005, 07:03 PM   #12 (permalink)
Super Techie
 
Join Date: Jun 2004
Posts: 296
Default

Dont be like me and use a 6 year old power supply. 300watts and 8A on +12v rail.

i got an Antec 430wTruePower2.0 comin in soon, so i dont have to worry about it.

__________________

__________________

AMD Athlon 64 3200+ \"Venice\"
ASRock 939Dual-SATA2
2GB OCZ Platinum DDR400
eVGA 256mb 6800GT
ANTEC 430watt TruePower 2.0
WD 160GB 8MB cache HDD
NEC 16x Dual Layer DVD+/-RW
xteam02001 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.