I would not do it..... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Overclocking and Modding
Closed Thread
Thread Tools Display Modes
Old 03-13-2011, 07:42 PM   #1 (permalink)
Newb Techie
Join Date: Mar 2011
Posts: 1
Exclamation I would not do it.....

I would not keep your cover open because this is what Apple says:
Always shut down the computer before opening it to avoid damaging its
internal components or the components you are installing. Do not open the computer
or attempt to install items inside it while it is on.
I have a Power Mac G5, i ran it with the cover open once, and then it just randomly got slower. I dusted it, and it got a little faster. I really don't think their is a problem with running it with the cover open, but I don't do it because Apple says not to.

jimgeo is offline  
Old 03-13-2011, 09:07 PM   #2 (permalink)
TF's First Dry Ice User!
Peter.Cort's Avatar
Join Date: Jul 2007
Location: Boston, MA
Posts: 5,018
Default Re: I would not do it.....

well if you're going to install new components you should always shut it off, that's basic electronics. And I've never had an issue with running any of my pc's open and having them run slower, it might just be the placebo effect because whether or not it's open won't effect how it runs.

A notice to EVERYONE who has posted here with a computer problem, I highly encourage you to keep current with the forums, even if it's browsing for 10-15 minutes during lunch, or before you go to bed at night. There are many things that you can learn and apply to future issues. My goal is to help people get to a point where they can use their own knowledge to help themselves, and others.

Also please use the search button. You've got a 50/50 chance that someone's asked your question and we've answered it.
Peter.Cort is offline  
Old 03-18-2011, 07:04 PM   #3 (permalink)
The Water Cooling Guru
aspire's Avatar
Join Date: Feb 2005
Location: United States
Posts: 5,308
Default Re: I would not do it.....

Thanks for a good laugh,

My computer hasn't had the side panel on for months, a couple well placed fans hanging around the inside have been helping keep it cool.
If I help you with something, you think I'm the bomb, or you just like what I said, rep me by clicking the star under my post.


The Official Tech Forums Water Cooling Informational Guide
aspire is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.