Help, Please! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Overclocking and Modding
Closed Thread
Thread Tools Display Modes
Old 04-29-2004, 11:02 PM   #1 (permalink)
Newb Techie
Join Date: Apr 2004
Posts: 4
Question Help, Please!

i got a new computer case and i put everything into my new case and when i go and turn it on the fans go, light go on, but my usb ports and my monitor doesnt show a picture.. Can anyone helo me with this problem..

Redsand is offline  
Old 04-30-2004, 03:26 AM   #2 (permalink)
Monster Techie
Join Date: Oct 2003
Posts: 1,878
Send a message via ICQ to Demalii Send a message via AIM to Demalii Send a message via Yahoo to Demalii

check all connections first.. make sure everything is snug, then if no picture, check to see if the video card is seated right.. there's more options, but usually the connections aren't good, so go check.. go go!

Demalii is offline  
Old 05-01-2004, 05:25 PM   #3 (permalink)
Junior Techie
Join Date: May 2004
Posts: 42

Does it beep at you - If so it's the POST telling you what's wrong. AGP cards can be buggers to seat correctly, wiggle it (whilst maintaining pressure to seat it, wiggle yer RAM too.

>but my usb ports and my monitor doesnt show a picture

USB ports don't work? What USB devices? What OS?

Signatures reduce bandwidth
HippyWarlock is offline  
Old 05-03-2004, 12:45 AM   #4 (permalink)
Newb Techie
Join Date: Apr 2004
Posts: 4

yea it beeps at me.. it goes on and off every 5 secs or so.. is it just my video card that might be loose..?
Redsand is offline  
Old 05-03-2004, 06:41 AM   #5 (permalink)
Ultra Techie
Join Date: Mar 2004
Posts: 767
Send a message via AIM to Monster00

check ur CPU and make sure its in right. i was with my friend on friday and we coulden't turn his pc on so i took off the cpu fan and cpu pulled out with the fan. I just put it back in and it worked great.
Intel 2.8GHZ 800mhz FSB
Western digital 120 GB HD
Western digital 40 GB HD
Asus P4p800s motherboard
1280MB of ram
Xaser III Red and Blue case
Antec 550 watt PSU
BACK TO GOOD OLE CPU FANS(serious not kidding)
ATI readon 9800xt 256 MB
8x DVD burner
52X cd burner
Monster00 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.