Techist - Tech Forum - View Single Post - FreeAgent External Hard stopped working (unknown, not initialized)

Click Here to Login
View Single Post
Old 02-15-2015, 02:59 AM   #1 (permalink)
Sedhadi
Virgin Techie
 
Join Date: Feb 2015
Location: Tehran
Posts: 1
Default FreeAgent External Hard stopped working (unknown, not initialized)

Hi everybody

Yesterday, I was working with my PC while my 1TB Seagate external hard (Amazon.com: Seagate FreeAgent GoFlex 1 TB USB 3.0 Ultra-Portable External Hard Drive in Black STAA1000101: Electronics) was plugged in via USB. The USB connection was a little bit loose.

Then when I was plugging a USB flash memory in, I noticed that the external hard was disconnected.
I connected it again, but it didn't appear in My Computer.
Here is the state in Disk Management and Device Manager:



After that, I plugged out the "SATA to USB converter" from the hard and connected it directly to SATA cable inside the PC case (like internal HDD), but this time nothing showed up in Disk Management, Device Manager and BIOS. However, it took a long time for the system to boot.


I searched and read lots of threads and tested some other stuff:





(It didn't appear in Minitool Partion Wizad).

I've got a lot of data on this HDD which really matters to me.
Any help is really appreciated.
__________________
Sedhadi is offline   Reply With Quote
 


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.