Techist - Tech Forum - View Single Post - crysis omg

Click Here to Login
Thread: crysis omg
View Single Post
Old 06-11-2007, 08:50 PM   #6 (permalink)
Ste
Do not Stare at my Avatar
 
Ste's Avatar
 
Join Date: Aug 2005
Location: Upon Gleaning Infinity
Posts: 9,578
Send a message via MSN to Ste
Default Re: crysis omg

Quote:
Originally Posted by b1gapl View Post
Vista is required to play Crysis, because of DX10. A 6600GT would pretty much fail at playing that game. Better to upgrade the graphic card. And also your processor.
Firstly, DX10 will eventually be released for XP. (Don't ask me when, but they only have it for vista now so the uneducated will go, OMG DX10 only!! MUST UPGRADE!!!MUST SPEND MONEY!!!)
Secondly, unless they are retarded they are going to release it with an option to play in DX9 or DX10, if DX10 has not come out for XP yet..

Unless your telling me that the programmers and creators of crysis have definitly and clearly stated that they will only be releasing the Game for Vista. And which case that is the dumbest marketing move ever. And therefore they are retarded and should kill themselves.

__________________
Ste is offline  
 


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.